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Disclaimer 
 

The information contained in this document is the proprietary information of Telit Communications S.p.A. 
and its affiliates (“TELIT”).  

The contents are confidential and any disclosure to persons other than the officers, employees, agents 
or subcontractors of the owner or licensee of this document, without the prior written consent of Telit, is 
strictly prohibited. 

 

Telit makes every effort to ensure the quality of the information it makes available. Notwithstanding the 
foregoing, Telit does not make any warranty as to the information contained herein, and does not 
accept any liability for any injury, loss or damage of any kind incurred by use of or reliance upon the 
information. 

 

Telit disclaims any and all responsibility for the application of the devices characterized in this 
document, and notes that the application of the device must comply with the safety standards of the 
applicable country, and where applicable, with the relevant wiring rules. 

 

Telit reserves the right to make modifications, additions and deletions to this document due to 
typographical errors, inaccurate information, or improvements to programs and/or equipment at any 
time and without notice.  

Such changes will, nevertheless be incorporated into new editions of this document. 

 

Copyright: Transmittal, reproduction, dissemination and/or editing of this document as well as utilization 
of its contents and communication thereof to others without express authorization are prohibited. 
Offenders will be held liable for payment of damages. All rights are reserved.  

 

Copyright © Telit Communications SpA 2008 – 2009. 
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Applicable Products 
 

 

GE863-PRO3                           
 
 

GE863PR3***-*** 
GE863P3******** 

The suffix “***-***” and “********” depends on the module 
/ configuration and packaging.  

Please contact your Telit representative  for  details 
 

 
 
 
 
 
 
 

Linux SW Version Recommended  
U-Boot version 

05.0005 20.00.0000 
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1 Introduction 

1.1 Scope 
 
This user guide serves the following purpose: 
 

• Describes how to install Telit Development Environment. 
• Describes how to develop, deploy and debug a simple application on the PRO3 with Linux 

operating system. 

1.2 Audience 
 
This User Guide is intended for software developers who develop applications in Linux on the GE863-
PRO³ module. 

1.3 Contact Information, Support 
 
Our aim is to make this guide as helpful as possible. Keep us informed of your comments and 
suggestions for improvements. 
 
For general contact, technical support, report documentation errors and to order manuals, contact Telit’s 
Technical Support Center at: 
 
TS-EMEA@telit.com or http://www.telit.com/en/products/technical-support-center/contact.php 
 
Telit appreciates feedback from the users of our information. 
 

1.4 Open Source Licenses 
 
Telit Development Environment consists of different Open Source Software licensed as described in the 
following paragraphs. 
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1.4.1 Linux 
 
Linux is an operating system for computers; it was originally created starting in 1991 by Finnish 
programmer Linus Torvalds with the assistance of developers from around the globe. It is licensed under 
the Free Software Foundation's GNU Project's GNU General Public License, version 2. 

1.4.2 coLinux 
 
Cooperative Linux (short-named coLinux) is a port of the Linux kernel that allows it to run cooperatively 
alongside another operating system on a single machine. It is released under GNU General Public 
License. 

1.4.3 Xming 
 
Xming is the leading free unlimited X Window Server for Microsoft Windows. It is released under 
MIT/X11 license. 
 

1.4.4 Eclipse IDE 
 
Eclipse is an open source community, whose projects are focused on building an open development 
platform comprised of extensible frameworks, tools and runtimes for building, deploying and managing 
software across the lifecycle. Its projects are released under the Eclipse Public License. 

1.5 Product Overview 
 
The GE863-PRO3 is an innovation to the quad-band, RoHS compliant GE863 product family which 
includes a powerful ARM9TM processor core exclusively dedicated to customer applications. The concept 
of collocating a powerful processor core with the GSM/GPRS engine allows developers to host their 
application directly. The PRO3 incorporates much of the necessary hardware for communicating 
microcontroller solutions, including the critical element of memory, significant simplification of the bill of 
material, vendor management, and logistics effort are achieved. 

1.6 Document Organization 
 
This manual contains the following chapters: 
 

- “Chapter 1, Introduction” provides a scope for this manual, target audience, technical contact 
information, and text conventions. 
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- “Chapter 2, PRO3 Hardware interfaces” describes the various hardware interfaces of the PRO3. 
- “Chapter 3, Development Environment” describes the files provided with the installer, the 

hardware requirements and the installation process. 
- “Chapter 4, Connecting the Target to the Host” describes how to setup the various possible 

connection configurations between the target and the host. 
- “Chapter 5, Starting Eclipse” describes the first steps with the IDE. 
- “Chapter 6, Creating a Project” describes how to create a C/C++ project and how to deploy it to 

the target. 
- “Chapter 7, Debugging an Application” describes how to debug your programs. 
- “Chapter 8, General Suggestion“ contains some practical advices 
- Various appendixes with useful information for other tasks. 

1.7 Text Conventions 
 
This section lists the paragraph and font styles used for the various types of information presented in this 
user guide. 
 
Format Content 
Arial monospaced Linux shell commands at command prompt. 

1.8 Related Documents 
 
The following documents are related to this user guide: 
 

[1] TelitGE863PRO3 Hardware User Guide 1vv0300773a 
[2] TelitGE863PRO3 EVK User Guide 1VV0300776 
[3] TelitGE863PRO3 Linux SW User Guide 1vv0300781 
[4] TelitGE863PRO3 Linux GSM Library User Guide 1vv0300782 
[5] TelitGE863PRO3 Product Description 80285ST10036a 
[6] TelitGE863PRO3 U-boot Software User Guide 1vv0300777 

 
 

 
All documentation can be downloaded from Telit’s official web site www.telit.com if not otherwise 
indicated. 
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1.9 Document History 
RReevviissiioonn  DDaattee  CChhaannggeess  
ISSUE #0 26/05/08 First Release 
ISSUE #1 31/07/08 Added new paragraph: 

8  General Suggestion 
ISSUE #2 21/05/09 6.2 Linking an application against a library: Added 

Appendix E: Upgrading the firmware kernel sources… modified 
Appendix F: Upgrading U-boot… added 
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2 PRO3 Hardware interfaces 
 
 
 
 

 

 
 

For further details about hardware interfaces refer to document [1] and document [2]. 

Ethernet Port 

USB  
“Device Port” 

USB  
“Host” Port 

Serial Port 
“Upper=AP UART 0” 
Used for debugging 

Serial Port 
“Lower=AP DEBUG” 

Used for the 
Command Shell 
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3 Development environment 
This section contains information about the development environment for the host. The development 
environment is based on coLinux and Xming that permit you to work in Linux under Microsoft Windows 
XP. 

3.1  Available Files  
 
The development environment consists of the following file: 
 

 setupDevEnvironment_C_Cpp.exe: the development environment C/C++ version. 

This file is available on the Telit web site www.telit.com in the download zone. 

3.2 System Requirements 

To install the development environment, a 32-bit x86 platform with the following characteristics is 
required: 

• Microsoft Windows XP installed 

• At least 1GB of Ram 

• 5,1 GB of hard disk space 

3.3  Installation 

This paragraph shows how to install and configure the development environment on a Windows XP-
based host PC. Note that the development environment must be installed with an administrator account. 
 

For a correct installation and usage of Telit Development Environment it is strongly 
suggested to turn off any software firewall (especially Windows Firewall service) active 
in the host system. Otherwise an aimed configuration of the firewall is needed in order 
to allow the communications between Windows and coLinux. 
 
Note that the installation will create a C class network 192.168.121.0: if you already 
have in your system such a network you have to change manually, after the 
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installation, all the 192.168.121.x addresses to a free address space in your 
network. Refer to Appendix A for details. 
 

Note that a new installation of the development environment will completely destroy a 
previous installation, if present. Refer to Appendix B to learn how to make a back-up. 
 

3.3.1 Installation of the development environment 
 
Run the installation of the development environment by clicking twice on the 
setupDevEnvironment_C_Cpp.exe file and follow the instructions on the screenshots: 
 
 

 
 
 
Click Next. 
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Carefully read the information then click Next. 
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Choose the directory, where Telit Development Platform should be installed, according to the 
following rule: 
 

• The directory tree must end with the directory coLinux in such a way:  
 
[device letter]:[path]\colinux 
 
where [path] is a filesystem path preferably without spaces. Some examples are: 
 
c:\colinux (PREFERRED) 
c:\telit\colinux 
 
Note that all the other packages should be installed inside this directory. For example, 
considering Xming: 
 
c:\colinux\Xming 
c:\telit\colinux\Xming 
 

After choosing the directory click Next. 
 

 
 

Click Install. 
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You will be asked to install coLinux: if you haven’t previously installed it click Ok, otherwise click Cancel 
and skip to Xming installation. 
 
If you have chosen to install coLinux follow the next screenshots: 
 

 
 
Click Next. 
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Click I Agree. 
 

 
 

Uncheck the voice Root Filesystem image Download and click Next. 
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Select the previously chosen Telit Development Installation directory (for example c:\colinux 
or c:\telit\colinux). 
 
 

 
 

Click Next. 
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Click Continue Anyway. 
 

 
 

Uncheck the voice Show Readme and click Finish. 
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After installing coLinux (or choosing not to install it) you will be asked to install Xming. 
 

 
 

If you haven’t previously installed it click Ok, otherwise Cancel and skip to the file system image 
installation. 
 
If you have chosen to install Xming follow the next screenshots: 
 

 
 

Click Next. 
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Click Browse to select the previously chosen Telit Development Platform installation 
directory. The installer will automatically add the path part for Xming (according to the 
previous examples the path will become c:\colinux\Xming or c:\telit\colinux\Xming). 
 

 
 

Click Next. 
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Click Next. 
 

 
 



 
 
 
 

 
Development Environment User Guide for PRO3 with Linux 

1vv0300780 Rev.2 -21/05/09 
 

Reproduction forbidden without Telit Communications S.p.A. written authorization - All Rights Reserved  page 22 of 91 
 

Click Next. 

 
 

Click Install. 
 

 
 

Uncheck the voice Launch Xming and click Finish. 
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After installing Xming (or choosing not to install it) you will be prompted with the following window: 
 

 
 

 
Select the previously chosen Telit Development Platform installation directory and click Extract 
(normally the directory is already correct and you have only to click Extract). Please note that this step 
can last several minutes. 
 

 
 

Click Next. 
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Click Finish. 

 
As previously explained, if you already have in your system the 192.168.121.0 network it is 
time to change the IP addresses of the development environment: refer to Appendix A for 
further details.  
 

Go to Network Connections, right click on the device called TAP-Win32 Adapter V8 and choose the 
menu voice Properties. Select the Internet Protocol (TCP/IP) and click on the button properties; you 
should see the following window: 
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If this configuration is not available, you have to manually insert the following values: 
 
IP address: 192.168.121.1 
Subnet mask: 255.255.255.0 
 
then click Ok. 
 
Go to Start menu → All Programs → Telit Development Platform → Start Colinux. 
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After loading, go to Start menu → All Programs → Telit Development Platform → Telit Customized 
Eclipse. The first time you launch the application you will be prompted with the following window: 
 

 
 

Click Yes. 
 
Congratulations, you have installed Telit Development Platform. 

3.3.2 Starting coLinux 
 
Before using any component of the development environment you have to start coLinux going to Start 
menu → All Programs → Telit Development Platform → Start Colinux. 
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4 Connecting the target to the host 
To get the most out of the development environment it is necessary to create an IP connection through 
the target and the host.  There are two options: using a normal Ethernet connection via RJ45 port or 
using an Ethernet on USB connection via USB port. The first step is to configure the target. 
 
Please note that if you have executed the procedure in Appendix A, in the following paragraphs you 
have to consider the new IP addresses values instead of the written ones. 

4.1.1 Configuring the target: connection via RJ45 
 
Turn on the target, connect the Ethernet cable and open a terminal; after the boot type: 
 
modprobe macb 
ifconfig eth0 hw ether AA:BB:AA:BB:AA:BB 
ifconfig eth0 192.168.121.3 netmask 255.255.255.0 
 
to configure the network interface; then, type: 
 
telnetd 
 
to start the telnet daemon. 
 
For further details about Ethernet configuration refer to document [3]. 

 
Note that you have to repeat these configuration steps each time the target is started. It is 
possible to make the process automatic: refer to 4.1.4 for details. 
 
 

4.1.2 Configuring the target: connection via USB 
 
Turn on the target and open a terminal; after the boot type: 
 
modprobe g_ether 
 
then connect the USB cable. 
 
If this is the first time you use the connection via USB you have to configure Windows. 
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Note that Windows driver installation is needed only if it is the first time you use the USB 
connection or if you change USB port. Otherwise you can skip over this part and go directly to 
the IP configuration with ifconfig (page 31). 
 

Plug the USB cable into the target’s USB Device port (B-type) and into the PC (A-type): you will be 
asked for a driver "Linux USB Ethernet/RNDIS Gadget". Follow the actions described by the 
screenshots: 
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Click the Browse button and search for the file linux.inf, given with Telit package inside coLinux 
installation directory. 
 

 
 

Click Continue Anyway. 
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Now, type in the terminal: 
 
ifconfig usb0 192.168.121.3 netmask 255.255.255.0 
 
to configure the IP address. Then, type: 
 
telnetd 
 
to start the telnet daemon. 
 
For further details about Ethernet on USB configuration refer to document [3]. 

 
Note that you have to repeat these configuration steps (excluding the Windows driver 
installation) each time the target is started. It is possible to make the process automatic: refer 
to 4.1.4 for details. 
 
Note that after a reboot of the target you have to un-plug and plug the USB cable to make the 
connection work. 
 
 

4.1.3 Configuring the host Ethernet connection 
 
Close all the applications opened in the development environment and coLinux itself. Go to My Network 
Places → View Network Connections and identify the following two connections: 
 

• The virtual connection used for coLinux whose Device Name is “TAP-Win32 Adapter V8 
(coLinux)”. 

• The connection used for the target (it could be a normal Ethernet link or the Ethernet on USB 
link). 

 
You can find an example on the image below: 
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Select the two connections. 
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Once selected, right click and choose the voice Bridge Connections. 
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If the operation is successful you should see a new network bridge like pictured in the following image (if 
the bridge doesn’t show up reboot your Windows system): 
 

 
 

Right click on the Network Bridge and choose the voice Properties 
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Select the voice Internet Protocol (TCP/IP) and click the button Properties. 
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Check the radio button Use the following IP address and insert these data: 
 

• IP address: 192.168.121.1 
• Subnet mask: 255.255.255.0 

 

 
 

 
Click the Ok button, then the Close button. 
 
The host configuration is complete. To test its working, start coLinux and open a windows shell; type: 
 
ping 192.168.121.2 
 
to check for the connection to coLinux. Type: 
 
ping 192.168.121.3 
 
to check for the connection to the target. 
 
Summarizing network configuration after default installation: 
 
Windows IP address: 192.168.121.1 
coLinux IP address: 192.168.121.2 
GE863-PRO3 IP address: 192.168.121.3 
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4.1.4 Making the target IP configuration automatic 
 
In order to avoid manual IP configuration of the target each time it is rebooted you can follow these 
steps: 
 

• Type in the terminal: 
 
vi /etc/init.d/S00 
 

• At vi prompt, press the ‘i’ key on the keyboard to enter in edit mode. 
 

 
 

• For Ethernet RJ45 connection type: 
 
modprobe macb 
ifconfig eth0 hw ether AA:BB:AA:BB:AA:BB 
ifconfig eth0 192.168.121.3 netmask 255.255.255.0 
telnetd 
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• For Ethernet on USB connection type: 
 
modprobe g_ether 
ifconfig usb0 192.168.121.3 netmask 255.255.255.0 
telnetd 
 

• Press the ‘Esc’ key, then press the following keys on the keyboard in succession: ‘:wq’ and 
‘Enter’. You should see again the shell prompt 

 

 
 
 
After reboot the IP configuration should be working. 
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5 Starting Eclipse  
 
To start the IDE follow these steps: 
 

• Be sure that Colinux has been started (to start it go to Start menu → All Programs → Telit 
Development Platform → Start Colinux). 

• After loading, go to Start menu → All Programs → Telit Development Platform → Telit 
Customized Eclipse. 

• You will be prompted to choose a location in the filesystem for creating the workspace. A path 
without spaces is recommended. Note that you can find your Windows filesystem in 
/mnt/windows/. 
 

 
 

 
• When the workspace has been created click on the Workbench icon. 
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Now you are ready to develop your first application for the Pro3. 
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6 Creating a project 

6.1 C or C++ project 
 
To create a project, follow these steps: 
 

• Open the IDE (Start menu → All Programs → Telit Development Platform → Telit Customized 
Eclipse). 

• Open the menu File → New → C Project. As an alternative, you can right click on the Project 
Explorer frame and select the C Project like shown in the picture below: 
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Choose a name for the project and its location, and then select the ARM uclibc C executable for C 
projects or Arm Cpp/C executable for C++ or mixed C++/C projects. Click Next. 
 

 
 

 
 
 
 
 
 
 
 
 



 
 
 
 

 
Development Environment User Guide for PRO3 with Linux 

1vv0300780 Rev.2 -21/05/09 
 

Reproduction forbidden without Telit Communications S.p.A. written authorization - All Rights Reserved  page 43 of 91 
 

Now you can choose the configuration for your project. Make sure that at least one configuration is 
selected. Click Finish. 

 

 
 

 
 
 
 
 
 
 
 
 
 



 
 
 
 

 
Development Environment User Guide for PRO3 with Linux 

1vv0300780 Rev.2 -21/05/09 
 

Reproduction forbidden without Telit Communications S.p.A. written authorization - All Rights Reserved  page 44 of 91 
 

The following alert may appear: 
 

 
 

Select “Yes” to proceed. 
 

A folder with the newly created project will now appear in the Project Explorer section; it is empty 
because currently there are no files. In order to add a new file, right click on the project name and select 
New → File in the context menu. 
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Now write the desired file name in the appropriate field (if necessary write also the subdirectory where 
the file should be located) and then click on the Finish button in order to end the file creation procedure. 
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A blank text editor sheet will now appear in the main frame where you can write your application. In the 
following example, the classic “Hello world!” program is shown.  
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In order to build the application, select the menu option Project → Build Project. You should see in the 
console the messages shown below: 

 

 
 
After a successful compilation, the binary file will be stored in the directory /<your workspace 
directory>/Project_Name/Release/.  
 

Please note that C++ programs need libraries which, by default, are not present in the target. 
Refer to Appendix D for further details. 
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6.2 Linking an application against a library 
If your application makes use of an external library, the library itself and its header files must be into the 
Colinux Development Environment.  
So start the Colinux console (Windows Start Menu → All Programs → Telit Development Platform 
→ Console) and make sure that all the library components are correctly installed.  
To find out the library type: 
 
# ls /opt/crosstools/lib 

or 
 
# ls /opt/crosstools/telit/lib 

 

then type: 
 
# ls /opt/crosstools/usr/include 

or 
 
# ls /opt/crosstools/telit/include 

 

to find out the library header files. 

Whenever the library you want to use is not into the Colinux Development Environment, you can install it. 
Let’s assume, for example, you want to install the libpthread.a library (which is actually already installed 
into the Colinux Development Environment).  
Copy the library typing: 
 
# cp /mnt/windows/<PATH>/libpthread.a /opt/crosstools/lib 

  
Copy the header file typing: 
 
# cp /mnt/windows/<PATH>/pthread.h /opt/crosstools/usr/include 
 
where <PATH> is the windows folder where you have stored the library files. For example, if you store 
them within C:\Temp you have to type: 
  
# cp /mnt/windows/Temp/libpthread.a /opt/crosstools/lib  
 
and 
 
# cp /mnt/windows/Temp/pthread.h /opt/crosstools/usr/include 
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Once all the library components have been correctly set up, the application can be linked against the 
library itself. Under Eclipse right click on the project folder and select Properties as shown below: 
 

 
 
 
The Properties tab for the application will appear. Now, from the C/C++ Build left menu, select Settings 
and then, from the Tool settings tab, select Libraries as shown below. 
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Now push the Add button (highlighted above) to link the library. Simply type the pthread value when the 
window below will appear and then push the OK button.  

 

 
Please note that the ‘-l’ linker option automatically completes the library name with the ‘lib’ prefix: 
therefore there is no need to indicate the full library name (libpthread). 
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Once libpthread.a has been successfully added to the project, push the Apply and then the OK buttons 
of the main tab. Now the project using libpthread.a is ready to be compiled. 
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6.3 Downloading a file to the target 
 
Once the project has been compiled, you can download it to the target. There are two possible options: 
 

• Downloading the file using the Ethernet/USB port 
• Downloading the file using the serial port. 

6.3.1 Download through the Ethernet/USB port 
 
The simplest way to download the binary of a project is to use the IDE (note that the telnet daemon must 
be running in the target). 
 
Highlight the project whose binary is going to be transferred and go to Telit → Download binary to 
GE863-PRO3 or click on the button highlighted by the red circle in the picture. 
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Alternatively, in the Project Explorer, you can right-click on the binary to be transferred, and choose the 
voice Telit → Download Binary to Target of the pop-up menu: 
 

 
 
 
 
 
If the transfer succeeds you should see in the console a similar message: 
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The binary can be found in the root directory of the target filesystem. 

 
Pay attention that the first method will work only if the binary has the same name of the 
selected project and if the binary can be found inside the Release directory of the project. 
 
 

If you need to download to the target any other file than the compiled binary of a project follow these 
steps: 
 

- Go to Telit → Download file to GE863-PRO3 or click on the button highlighted by the red circle 
in the picture. 

 

 
 
 

- Use the file selector to choose the file to be transferred and click Ok. 
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Alternatively, in the Project Explorer, if you have in a project the file to be transferred, you can right-click 
on it and choose the voice Download File to Target of the pop-up menu. 
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If the transfer succeeds you should see in the console named Telit Command Output a similar message: 
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Alternatively you can choose not to use the IDE: 
 

- Go to Start → Telit Development Platform → Console. 
- Copy the files to be transferred in the directory /var/www/apache2-default/, for example 

opening a terminal and using the cp command: 
 
cp <file_to_be_copied> /var/www/apache2-default/ 
 

- From the target shell, within the directory where you want to place the downloaded file, type: 
 
wget http://192.168.121.2/apache2-default/file_to_be_copied 

 

 
 
If the file is an application you need to change its permission to execute it. Therefore type: 
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chmod 744 filename 

6.3.2  Download through the serial port 
 
Make sure your target “Upper=AP UART0” serial port is configured with the baudrate you wish to use for 
transferring the file. Open a console and type the following command to change the baudrate: 

 
stty ispeed [ baudrate ] < /dev/ttyS1 

 
 
Then type: 
 

rz --zmodem </dev/ttyS1 >/dev/ttyS1 
 

in order to let the target receive your binary file through the zmodem protocol using ttyS1. 
 
Now use the “send file” option from your terminal (make sure that zmodem file transfer option has been 
set) to download your application to the target.  
 
If the file is an application you need to change its permission to execute it. Therefore type: 
 

chmod 744 filename 
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7 Debugging an application 

7.1 Overview 
 
Telit Development Environment allows remote debugging on the target through Ethernet/USB 
connection. Two applications are needed: 
 

• gdbserver: server part of the debugger which runs in the target; it must be launched every time 
the debugging starts. The file can be found in coLinux filesystem directory 
/opt/crosstools/arm-linux-uclibc/target_utils/gdbserver and it needs to be 
copied in the target using one of the methods seen in chapter 6. Remember to set the executable 
flag for the file using the chmod command as explained in 6.3.2. You also need to copy in the 
target (inside the /lib/ directory) libthread_db.so.1 that can be found in coLinux filesystem 
directory /opt/crosstools/lib. 

• arm-linux-gdb: client part of the debugger which runs in coLinux. The file can be found in coLinux 
filesystem directory /opt/crosstools/usr/bin/arm-linux-gdb. It commands the 
debugger behaviour and it is used through a graphical user interface in Telit Development 
Environment provided by Eclipse. 

 
Both the server and the client need to be configured as explained in the following paragraphs. 

7.2 Configuring the Debugger 

7.2.1 Creating a Debug Launch Configuration 

 
Before start debugging your application, a Debug Launch Configuration for the project shall be created 
into Eclipse. 
The Debug Launch Configuration locates the GDB debugger for Eclipse, locates the project’s executable 
file (in this case it is used only to look up symbol information), and provides a startup script of GDB 
commands that are to be run as the debugger starts up. 
A Debug Launch Configuration will be created for each project. 
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Select the menu option “Run → Open Debug Dialog…” to bring up the Debug Configuration Window. 
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In the “Debug – Create, manage, and run configurations” window below, click on “Zylin Embedded 
debug (Native)” followed by the “New” button. 
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The Debug “Create, manage and run configurations” window changes to the dialog shown below. Start 
by making sure that the “Main” tab is selected. 
 
In the “Name:” text box, enter the name of this debug launch configuration (usually the project name). In 
this example use the “Hello”. 
In the “Project” text box, use the “Browse…” button to find the project “Hello”.  
 
In the “C/C++ Application” text box, use the “Search Project…” button to find the executable “Hello”. 
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Now select the “Debugger” tab as shown below.  
 
In the text box labeled “GDB Debugger:” use the “Browse...” button to locate the “arm-linux-gdb” file. It 
will be found in the “/opt/crosstools/usr/bin” folder. 
 
Finally remove the “.gdbinit” GDB init script filename from the “GDB command file:” text box. 
 

 
 
 
GDB can communicate with the target over an IP network/Ethernet-link-on-USB using TCP or UDP.GDB 
– IP network connection configuration (Ethernet or USB) 
 
Select the “Commands” tab. 
If your target is accessible through a network cable, in the “’Initialize’ commands” text window, enter the 
following GDB startup commands, as shown in the picture below: 



 
 
 
 

 
Development Environment User Guide for PRO3 with Linux 

1vv0300780 Rev.2 -21/05/09 
 

Reproduction forbidden without Telit Communications S.p.A. written authorization - All Rights Reserved  page 64 of 91 
 

 
 nosharedlibrary 
 set solib-absolute-prefix /opt/crosstools 
 symbol [ filename ] 
 target remote tcp:192.168.121.3:2345 
 tbreak main 
 continue 

 

 
 
 
In the previous lines [filename] refers to the binary to be debugged, including the file path (for example 
the default workspace is /root/workspace/project_name/Release/file_name). 
The “target remote tcp” command debugs using a TCP connection to port 2345 on 192.168.121.3 (the IP 
address you should use in the target if you have not changed default configuration). 
 
Click on “Apply” followed by “Close” to finish specification of the debug launch configuration for Hello 
debugging. Eclipse may ask you if you want to save this configuration, answer “Yes”.  
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The “Source” and “Common” tabs can be left in their default state. 

7.2.2 Organizing Favorites 
 
In order to simplify the debug process you can add the launch configuration that you wish to use in the 
Favorites. For example add the Hello embedded debug launch configuration into the Debug pull-down 
menu’s list of favorites.  
In the toolbar, click on the down arrowhead next to the debug symbol and then click “Organize 
Favorites…”. 
 

 
 

Click on “Add…” and either checkmark the “Hello” or click the “Select All” button.  
Finally, click “OK” to enter this debug launch configuration into the debugger list of favorites, as shown 
below. 
 

  

 
Now when you click on the Debug Toolbar button’s down arrowhead, you will see the “Hello” debug 
launch configuration installed as a favorite, as shown below. 
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Now everything is in place to debug the project. 
 
To debug, it is needed to switch from the C/C++ perspective to the Debug perspective. The standard 
way is to click on “Window → Open Perspective → Debug” as shown below. 
 

 
 
 

A more convenient way to switch perspectives is to click on the “perspective” buttons at the Eclipse 
upper-right window location. Click on the “OpenPerspective” toolbar button below on the left and then 
choose “Debug” when the other perspectives are displayed. 
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Now a “Debug” button is shown below. You may have to drag on the edge to expose all the perspective 
buttons. You can also right-click on any of the buttons and “Close” them in order to reduce the display to 
only the perspectives you are interested in. 
 

7.3 Running gdbserver 

7.3.1 Remote IP network connection 
 
As previously explained the gdbserver should be present in the target in the / directory and the 
libthread_db.so.1 in the /lib/ directory. 
 
Be sure your application (also a stripped version of this latter can be used) has been already copied into 
the target (see paragraph 6.3.1).  
 
If you are using the IDE, the simplest way to launch the debugger is highlighting the project to be 
debugged and going to Telit → Start Debugger or click on the button pointed out by the red circle in the 
following picture: 
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Alternatively, in the Project Explorer, you can right-click on the binary to be debugged, and choose the 
voice Telit → Start Debugger of the pop-up menu: 
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Note that the telnet daemon must be running in the target. If the operation succeeds you should see in 
the console named Telit Command Output a similar message: 
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If you want to manually start the gdbserver type in a target shell: 

 
./gdbserver 192.168.121.2:2345 [ filename ] & 

 
If The ‘host:2345’ argument means that gdbserver is to expect a TCP connection from machine ‘host’ 
(your workstation running Eclipse) to local TCP port 2345. 
[ filename ] is your application’s filename with its own path. 
 
It is recommended to let gdbserver run in background adding the “&” symbol to the command line as 
shown above. 
 
Now gdbserver listens on port 2345 for a remote connection. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7.3.2  Running GDB 
 
To start the Eclipse debugger, click on the “Debug” perspective button at the upper-right to open the 
Debug Perspective display, shown below. 
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If your display doesn’t look exactly like the debug display above, click on “Window → Show View” and 
select any of the missing elements. 
 
Once the server in the target has been started go to Run → Open Debug Dialog…, choose the debug 
configuration for the project you wish to debug and click the Debug button. 
 
In the screenshot below there are shown the components of the Debug perspective: 
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To start the debugging select the line Embedded GDB under the project name debug configuration row 
and click the green arrow highlighted in the screenshot. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Debug Control 

Variable display 
Breakpoint summary  
Register display, etc. 

C Code Display Assembler 
Display 

GDB Debugger 
Command Window 
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Now you are ready to debug your application. To set breakpoints double-click on the far left edge of the 
line. Double-clicking on the same spot will remove it. 
 

 
 

Note in the upper right “Breakpoint Summary” pane, the new breakpoint at line 5 has been indicated, as 
shown below. 

 

 
 
 
Use the debug control buttons shown below to control debugging. 
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See Eclipse’s Help Contents for further information. 
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8 General suggestions 
• Using a workspace in Windows filesystem it is not possible to rename an existing project: if you 

try the project name changes but connection to the files included is lost. 
• Using a workspace in Windows filesystem it is not possible to delete a project: if you try the 

project seems to be deleted in the workspace, but its files are still present in the filesystem. 
• Using a workspace in Windows filesystem sometimes Eclipse reports error in preferences saving, 

however this is only a warning.  
• If Eclipse reports error in saving files containing special characters you have to change text 

enconding preferences. Go to Windows → Preferences → General → Workspace → Text File 
Encoding and choose, for example, ISO-8859-1. 

• Occasional Xming crashes happen: close coLinux and restart it to solve the problem. 
• Using Ethernet on USB with a Windows bridge (ad described in chapter 4) causes ARP 

problems, i.e. the target doesn’t succeed in communicating with other systems if those haven’t 
previously sent data to it. This problem seems to be related in the RNDIS driver: a workaround is 
to manually insert entries in ARP table (for example in a startup script) for linking a NIC mac 
address to its IP address. The shell command to be used is: 
 
arp –s hostname hw_address 
 

• If the software “Putty” is present in your system be sure that its default configuration is ssh and 
not serial, otherwise Telit Development Environment applications won’t start. 
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Appendix A: How to change default IP 
addresses 
Telit Development Environment default installation will create a C class network 192.168.121.0; however 
it is possible that you already have in your system such a network. In this case, you have to manually 
change all the 192.168.121.x addresses to a free address space in your network. Follow these steps: 
 

• Start coLinux. 
• Go to Telit Development Environment installation directory and run colinux-console-fltk.exe. 
• After login (user: root, password: root) type in the console:  

 
nano /etc/network/interfaces 
 
and modify the rows 
 
address 192.168.121.2 
netmask 255.255.255.0 
 
with the proper addresses, then save the file.  
  

Pay attention that you always need to keep the correct correspondence 
between addresses. 

  
 

• Type in the console: 
 
nano /root/.profile 
 
and modify the row 
 
DISPLAY=192.168.121.1:0.0 
 
with the proper address, then save the file. 
 

• Type in the console: 
 
halt 
 
then close the coLinux window. 
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• Go to Telit Development Environment installation directory, enter in the Xming directory and open 
the file X0.hosts with a text editor. Modify the rows 
 
192.168.121.2 
192.168.121.1 
 
with the proper addresses, then save the file. 
 

• Modify the IP address of the network bridge according to the proper value (see paragraph 4.1.3  
for details). 
 

• Go to Start menu → All Programs → Telit Development Platform and right click on the item 
Console: modify the addresses 192.168.121.2 and 192.168.121.1:0.0 with the proper 
values, then click Ok. Repeat the same procedure for the items Telit Customized Eclipse, mc and 
Synaptic. 
 

• Start coLinux. 
 

• Launch Telit Customized Eclipse. 
 

• Go to Window → Preferences and click on the item Telit GE863 Preferences. Modify the 
addresses in coLinux IP address and GE863 IP address text boxes with the proper values. 
 

• When configuring the target IP address remember to use the new value; see paragraph 4.1.2 for 
details. 
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Appendix B: How to make a back-up 
If you wish to make a back-up of the entire development environment go to its installation directory and 
copy the following files: 
 

• root_fs.img 
• swap.img 

 
If you want to restore the system to this back-up, copy back the two files to the development 
environment installation directory. 
 

 
Please note that if your Eclipse workspace is in Windows filesystem this won’t be backed-
up. 
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Appendix C: Recovering from a serious 
error 
If the development environment doesn’t work anymore you can follow these steps to restore the system. 

 
THIS METHOD COMPLETELY DESTROYS ALL THE DATA YOU HAVE STORED INSIDE 
COLINUX FILESYSTEM. USE THIS ONLY IF YOU HAVE NOT ANY OTHER SOLUTION TO 
RESTORE THE SYSTEM! 
 

• If running, close coLinux. 
• Go to Telit Development Environment installation directory. 
• Double click on the file dskimageC_Cpp_dd_mm_yyyy.exe where dd_mm_yyyy is a date. 
• Click Extract. 

 
After several minutes the development environment will be restored. If this method doesn’t work uninstall 
the entire development environment (including coLinux and Xming), delete the installation directory and 
try to reinstall it following the steps reported in 3.3. 
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Appendix D: Copying C++ libraries in the 
target 
By default the target does not have the libraries necessary for C++ applications. In order to copy them 
follow these steps: 
 

• Start coLinux (Start menu → All Programs → Telit Development Platform → Start Colinux). 
• Open a console (Start menu → All Programs → Telit Development Platform → Console). 
• In the console type: 

 
mkdir /root/cpp_libraries 
cd /opt/crosstools/usr/arm-linux-uclibc/lib/ 
arm-linux-objcopy --strip-debug libstdc++.so.6 
/root/cpp_libraries/libstdc++.so.6 
arm-linux-objcopy --strip-debug libgcc_s.so.1 /root/ 
cpp_libraries/libgcc_s.so.1 
 

• Copy the two files (/root/cpp_libraries/libstdc++.so.6 and 
/root/cpp_libraries/libgcc_s.so.1) in the target using one of the methods described in 
previous chapters. 

• Move the two files in the target to the directory /lib. 
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Appendix E:  Upgrading the firmware kernel 
sources with Kernel Upgrade Tool 

Overview 
 
The Kernel Upgrade Tool is a Windows application used for upgrading kernel Linux in coLinux 
development environment. The updated kernel version depends on the tool version. 

Usage 
 
For using the Kernel Upgrade Tool follow these steps: 
 

- Double click on the file Telit-UpgradeKernel-<version_number>.exe and choose the directory 
where the tool can be unpacked. 
 

 
 

- Go to the directory where the tool has been unpacked and double click on the file 
 
UpgradeKernel.exe 
 
for launching the tool. 
 
 
 
 
 

- If you have kept the default ip addresses for coLinux and the target then simply click  the Start 
Upgrade button: 
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- When you are ready confirm the action clicking Ok, otherwise Cancel: 
 

 
 

- The upgrade takes some seconds. If the update succeeds it is shown the following pop-up: 
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• If the update doesn’t succeed a pop-up like this will appear: 
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- If you have not kept the default ip addresses for coLinux and the target then choose the 
Advanced Mode of the Radio Button and insert the proper ip address in the coLinux ip text field, 
then click the Start Upgrade button: 
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- If you want to see which updates the tool carry out click on Info → Show Updates: 
 

 
 
 

 
 

 
•  
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Appendix F: Upgrading U-boot with U-boot 
upgrade Tool 

Overview 
 
The u-boot Upgrade Tool is a Windows application used for upgrading u-boot in coLinux development 
environment. The updated u-boot version depends on the tool version. 

Usage 
 
For using the u-boot Upgrade Tool follow these steps: 
 

- Double click on the file Telit-UpgradeU-boot_<version_number>.exe and choose the directory 
where the tool can be unpacked. 
 

 
 

- Go to the directory where the tool has been unpacked and double click on the file 
 
UpgradeU-boot.exe 
 
for launching the tool. 
 
 
 
 
 

- If you have kept the default ip addresses for coLinux and the target then simply click  the Start 
Upgrade button: 



 
 
 
 

 
Development Environment User Guide for PRO3 with Linux 

1vv0300780 Rev.2 -21/05/09 
 

Reproduction forbidden without Telit Communications S.p.A. written authorization - All Rights Reserved  page 87 of 91 
 

 

 
 

- When you are ready confirm the action clicking Ok, otherwise Cancel: 
 

 
 

- The upgrade takes some seconds. If the update succeeds it is shown the following pop-up: 
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• If the update doesn’t succeed a pop-up like this will appear: 
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- If you have not kept the default ip addresses for coLinux and the target then choose the 

Advanced Mode of the Radio Button and insert the proper ip address in the coLinux ip text field, 
then click the Start Upgrade button: 
 

 
 
 
 
 

- If you want to see which updates the tool carried out click on Info → Show Updates: 
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Appendix G: Transferring files between 
coLinux and Windows 
For transferring files between coLinux and Windows filesystems it is possible to use a program called 
Midnight Commander (Start menu → All Programs → Telit Development Platform → Midnight 
Commander). 
 

 
 
It works as a normal file explorer: the window is divided into two columns, each one showing the content 
of a directory in the filesystem. Midnight Commander allows executing all normal operations on files 
(copying, renaming, deleting…). You can find the content of your Windows filesystem inside 
/mnt/windows. For help press F1. 
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Introduction


1.1 Scope


This user guide serves the following purpose:


· Describes how to install Telit Development Environment.


· Describes how to develop, deploy and debug a simple application on the PRO3 with Linux operating system.

1.2 Audience


This User Guide is intended for software developers who develop applications in Linux on the GE863-PRO³ module.

1.3 Contact Information, Support


Our aim is to make this guide as helpful as possible. Keep us informed of your comments and suggestions for improvements.


For general contact, technical support, report documentation errors and to order manuals, contact Telit’s Technical Support Center at:


TS-EMEA@telit.com or http://www.telit.com/en/products/technical-support-center/contact.php

Telit appreciates feedback from the users of our information.

1.4 Open Source Licenses


Telit Development Environment consists of different Open Source Software licensed as described in the following paragraphs.



1.4.1 Linux


Linux is an operating system for computers; it was originally created starting in 1991 by Finnish programmer Linus Torvalds with the assistance of developers from around the globe. It is licensed under the Free Software Foundation's GNU Project's GNU General Public License, version 2.

1.4.2 coLinux


Cooperative Linux (short-named coLinux) is a port of the Linux kernel that allows it to run cooperatively alongside another operating system on a single machine. It is released under GNU General Public License.

1.4.3 Xming


Xming is the leading free unlimited X Window Server for Microsoft Windows. It is released under MIT/X11 license.

1.4.4 Eclipse IDE


Eclipse is an open source community, whose projects are focused on building an open development platform comprised of extensible frameworks, tools and runtimes for building, deploying and managing software across the lifecycle. Its projects are released under the Eclipse Public License.

1.5 Product Overview


The GE863-PRO3 is an innovation to the quad-band, RoHS compliant GE863 product family which includes a powerful ARM9TM processor core exclusively dedicated to customer applications. The concept of collocating a powerful processor core with the GSM/GPRS engine allows developers to host their application directly. The PRO3 incorporates much of the necessary hardware for communicating microcontroller solutions, including the critical element of memory, significant simplification of the bill of material, vendor management, and logistics effort are achieved.


1.6 Document Organization


This manual contains the following chapters:

· “Chapter 1, Introduction” provides a scope for this manual, target audience, technical contact information, and text conventions.

· “Chapter 2, PRO3 Hardware interfaces” describes the various hardware interfaces of the PRO3.


· “Chapter 3, Development Environment” describes the files provided with the installer, the hardware requirements and the installation process.


· “Chapter 4, Connecting the Target to the Host” describes how to setup the various possible connection configurations between the target and the host.


· “Chapter 5, Starting Eclipse” describes the first steps with the IDE.


· “Chapter 6, Creating a Project” describes how to create a C/C++ project and how to deploy it to the target.


· “Chapter 7, Debugging an Application” describes how to debug your programs.


· “Chapter 8, General Suggestion“ contains some practical advices

· Various appendixes with useful information for other tasks.

1.7 Text Conventions


This section lists the paragraph and font styles used for the various types of information presented in this user guide.


		Format

		Content



		Arial monospaced

		Linux shell commands at command prompt.





1.8 Related Documents


The following documents are related to this user guide:

[1] TelitGE863PRO3 Hardware User Guide 1vv0300773a

[2] TelitGE863PRO3 EVK User Guide 1VV0300776

[3] TelitGE863PRO3 Linux SW User Guide 1vv0300781

[4] TelitGE863PRO3 Linux GSM Library User Guide 1vv0300782

[5] TelitGE863PRO3 Product Description 80285ST10036a

[6] TelitGE863PRO3 U-boot Software User Guide 1vv0300777


All documentation can be downloaded from Telit’s official web site www.telit.com if not otherwise indicated.


1.9 Document History


		Revision

		Date

		Changes



		ISSUE #0

		26/05/08

		First Release



		ISSUE #1

		31/07/08

		Added new paragraph:

8 
General Suggestion



		ISSUE #2

		21/05/09

		6.2
Linking an application against a library: Added


Appendix E: Upgrading the firmware kernel sources… modified


Appendix F: Upgrading U-boot… added








2 PRO3 Hardware interfaces
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For further details about hardware interfaces refer to document [1] and document [2].

3 Development environment

This section contains information about the development environment for the host. The development environment is based on coLinux and Xming that permit you to work in Linux under Microsoft Windows XP.

3.1  Available Files 


The development environment consists of the following file:


· setupDevEnvironment_C_Cpp.exe: the development environment C/C++ version.

This file is available on the Telit web site www.telit.com in the download zone.


3.2 System Requirements


To install the development environment, a 32-bit x86 platform with the following characteristics is required:


· Microsoft Windows XP installed


· At least 1GB of Ram

· 5,1 GB of hard disk space

3.3  Installation


This paragraph shows how to install and configure the development environment on a Windows XP-based host PC. Note that the development environment must be installed with an administrator account.

For a correct installation and usage of Telit Development Environment it is strongly suggested to turn off any software firewall (especially Windows Firewall service) active in the host system. Otherwise an aimed configuration of the firewall is needed in order to allow the communications between Windows and coLinux.


Note that the installation will create a C class network 192.168.121.0: if you already have in your system such a network you have to change manually, after the installation, all the 192.168.121.x addresses to a free address space in your network. Refer to Appendix A for details.


Note that a new installation of the development environment will completely destroy a previous installation, if present. Refer to Appendix B to learn how to make a back-up.

3.3.1 Installation of the development environment

Run the installation of the development environment by clicking twice on the setupDevEnvironment_C_Cpp.exe file and follow the instructions on the screenshots:
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Click Next.
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Carefully read the information then click Next.
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Choose the directory, where Telit Development Platform should be installed, according to the following rule:


· The directory tree must end with the directory coLinux in such a way: 

[device letter]:[path]\colinux

where [path] is a filesystem path preferably without spaces. Some examples are:

c:\colinux
(PREFERRED)
c:\telit\colinux

Note that all the other packages should be installed inside this directory. For example, considering Xming:

c:\colinux\Xming
c:\telit\colinux\Xming



After choosing the directory click Next.
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Click Install.
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You will be asked to install coLinux: if you haven’t previously installed it click Ok, otherwise click Cancel and skip to Xming installation.


If you have chosen to install coLinux follow the next screenshots:
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Click Next.
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Click I Agree.
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Uncheck the voice Root Filesystem image Download and click Next.
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Select the previously chosen Telit Development Installation directory (for example c:\colinux or c:\telit\colinux).
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Click Next.
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Click Continue Anyway.
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Uncheck the voice Show Readme and click Finish.


After installing coLinux (or choosing not to install it) you will be asked to install Xming.
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If you haven’t previously installed it click Ok, otherwise Cancel and skip to the file system image installation.


If you have chosen to install Xming follow the next screenshots:
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Click Next.
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Click Browse to select the previously chosen Telit Development Platform installation directory. The installer will automatically add the path part for Xming (according to the previous examples the path will become c:\colinux\Xming or c:\telit\colinux\Xming).
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Click Next.
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Click Next.
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Click Next.
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Click Install.
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Uncheck the voice Launch Xming and click Finish.


After installing Xming (or choosing not to install it) you will be prompted with the following window:
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Select the previously chosen Telit Development Platform installation directory and click Extract (normally the directory is already correct and you have only to click Extract). Please note that this step can last several minutes.
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Click Next.
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Click Finish.


As previously explained, if you already have in your system the 192.168.121.0 network it is time to change the IP addresses of the development environment: refer to Appendix A for further details. 

Go to Network Connections, right click on the device called TAP-Win32 Adapter V8 and choose the menu voice Properties. Select the Internet Protocol (TCP/IP) and click on the button properties; you should see the following window:
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If this configuration is not available, you have to manually insert the following values:


IP address: 192.168.121.1


Subnet mask: 255.255.255.0


then click Ok.


Go to Start menu → All Programs → Telit Development Platform → Start Colinux.
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After loading, go to Start menu → All Programs → Telit Development Platform → Telit Customized Eclipse. The first time you launch the application you will be prompted with the following window:
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Click Yes.


Congratulations, you have installed Telit Development Platform.

3.3.2 Starting coLinux


Before using any component of the development environment you have to start coLinux going to Start menu → All Programs → Telit Development Platform → Start Colinux.

4 Connecting the target to the host

To get the most out of the development environment it is necessary to create an IP connection through the target and the host.  There are two options: using a normal Ethernet connection via RJ45 port or using an Ethernet on USB connection via USB port. The first step is to configure the target.


Please note that if you have executed the procedure in Appendix A, in the following paragraphs you have to consider the new IP addresses values instead of the written ones.

4.1.1 Configuring the target: connection via RJ45


Turn on the target, connect the Ethernet cable and open a terminal; after the boot type:


modprobe macb


ifconfig eth0 hw ether AA:BB:AA:BB:AA:BB


ifconfig eth0 192.168.121.3 netmask 255.255.255.0

to configure the network interface; then, type:

telnetd

to start the telnet daemon.


For further details about Ethernet configuration refer to document [3].


Note that you have to repeat these configuration steps each time the target is started. It is possible to make the process automatic: refer to 4.1.4 for details.


4.1.2 Configuring the target: connection via USB

Turn on the target and open a terminal; after the boot type:


modprobe g_ether

then connect the USB cable.

If this is the first time you use the connection via USB you have to configure Windows.


Note that Windows driver installation is needed only if it is the first time you use the USB connection or if you change USB port. Otherwise you can skip over this part and go directly to the IP configuration with ifconfig (page 31).


Plug the USB cable into the target’s USB Device port (B-type) and into the PC (A-type): you will be asked for a driver "Linux USB Ethernet/RNDIS Gadget". Follow the actions described by the screenshots:
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Click the Browse button and search for the file linux.inf, given with Telit package inside coLinux installation directory.
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Click Continue Anyway.
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Now, type in the terminal:


ifconfig usb0 192.168.121.3 netmask 255.255.255.0

to configure the IP address. Then, type:


telnetd

to start the telnet daemon.


For further details about Ethernet on USB configuration refer to document [3].


Note that you have to repeat these configuration steps (excluding the Windows driver installation) each time the target is started. It is possible to make the process automatic: refer to 4.1.4 for details.


Note that after a reboot of the target you have to un-plug and plug the USB cable to make the connection work.


4.1.3 Configuring the host Ethernet connection


Close all the applications opened in the development environment and coLinux itself. Go to My Network Places → View Network Connections and identify the following two connections:


· The virtual connection used for coLinux whose Device Name is “TAP-Win32 Adapter V8 (coLinux)”.


· The connection used for the target (it could be a normal Ethernet link or the Ethernet on USB link).


You can find an example on the image below:
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Select the two connections.


[image: image35.jpg]% Network Connections

Fle Edt View Favortes Took Advanced Hep

Network Tasks

T Lacal frea Connection
Create anew cannection i)

@ Change vindows Frewal B 3, Eroadcom Netxireme 7 i
sottings

& Repai the selcted
commections

Other Places

B Controlpanel
&3 Wy etk Places
() My Documerts
My Computer

Details

2items selected,

2 cbjects selected






Once selected, right click and choose the voice Bridge Connections.
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If the operation is successful you should see a new network bridge like pictured in the following image (if the bridge doesn’t show up reboot your Windows system):
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Right click on the Network Bridge and choose the voice Properties
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Select the voice Internet Protocol (TCP/IP) and click the button Properties.


[image: image39.jpg]General | Authentication | Advanced
Adapters:

Soec th aapors o wen 0 s o comneet o compters
ot loca et
15 Loca A Comnection
S Locd A Comection3
oot

Configure.

Thicomnecton uses th olowing s
15 Clont o Mictosf Nt
12} e Pt St o Microsc Retwarks
15)005 Pocket Schecic

Fropertes

[ Show icon in notification area when connected

==n






Check the radio button Use the following IP address and insert these data:


· IP address: 192.168.121.1


· Subnet mask: 255.255.255.0
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Click the Ok button, then the Close button.


The host configuration is complete. To test its working, start coLinux and open a windows shell; type:


ping 192.168.121.2


to check for the connection to coLinux. Type:


ping 192.168.121.3


to check for the connection to the target.


Summarizing network configuration after default installation:


Windows IP address: 192.168.121.1


coLinux IP address: 192.168.121.2


GE863-PRO3 IP address: 192.168.121.3


4.1.4 Making the target IP configuration automatic


In order to avoid manual IP configuration of the target each time it is rebooted you can follow these steps:


· Type in the terminal:

vi /etc/init.d/S00



· At vi prompt, press the ‘i’ key on the keyboard to enter in edit mode.


[image: image41.jpg]863-PR erTerminal =
Fle Edt View Cal Transfer Heb
D@ %3 DB &

>

Jetc/init.d/S00 1/1 100%

@il

[auodetsct | 115200801 | SCROLL | CAPS | | Capture | Prntecho |







· For Ethernet RJ45 connection type:

modprobe macb
ifconfig eth0 hw ether AA:BB:AA:BB:AA:BB
ifconfig eth0 192.168.121.3 netmask 255.255.255.0
telnetd


· For Ethernet on USB connection type:

modprobe g_ether
ifconfig usb0 192.168.121.3 netmask 255.255.255.0
telnetd



· Press the ‘Esc’ key, then press the following keys on the keyboard in succession: ‘:wq’ and ‘Enter’. You should see again the shell prompt
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After reboot the IP configuration should be working.


5 Starting Eclipse 

To start the IDE follow these steps:


· Be sure that Colinux has been started (to start it go to Start menu → All Programs → Telit Development Platform → Start Colinux).

· After loading, go to Start menu → All Programs → Telit Development Platform → Telit Customized Eclipse.

· You will be prompted to choose a location in the filesystem for creating the workspace. A path without spaces is recommended. Note that you can find your Windows filesystem in /mnt/windows/.

[image: image43.jpg]& Workspacefaunchier

Sellect 2 workspace

Ecipse Platform stores your projects in a folder caled a workspace.
Choose  workspace folder o use for this session

e ~ | Bromae

[l e o e o








· When the workspace has been created click on the Workbench icon.
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Now you are ready to develop your first application for the Pro3.

6 Creating a project

6.1 C or C++ project


To create a project, follow these steps:

· Open the IDE (Start menu → All Programs → Telit Development Platform → Telit Customized Eclipse).


· Open the menu File → New → C Project. As an alternative, you can right click on the Project Explorer frame and select the C Project like shown in the picture below:
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Choose a name for the project and its location, and then select the ARM uclibc C executable for C projects or Arm Cpp/C executable for C++ or mixed C++/C projects. Click Next.
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Now you can choose the configuration for your project. Make sure that at least one configuration is selected. Click Finish.
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The following alert may appear:
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Select “Yes” to proceed.

A folder with the newly created project will now appear in the Project Explorer section; it is empty because currently there are no files. In order to add a new file, right click on the project name and select New → File in the context menu.
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Now write the desired file name in the appropriate field (if necessary write also the subdirectory where the file should be located) and then click on the Finish button in order to end the file creation procedure.
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A blank text editor sheet will now appear in the main frame where you can write your application. In the following example, the classic “Hello world!” program is shown. 
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In order to build the application, select the menu option Project → Build Project. You should see in the console the messages shown below:
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After a successful compilation, the binary file will be stored in the directory /<your workspace directory>/Project_Name/Release/. 

Please note that C++ programs need libraries which, by default, are not present in the target. Refer to Appendix D for further details.


6.2 Linking an application against a library


If your application makes use of an external library, the library itself and its header files must be into the Colinux Development Environment. 


So start the Colinux console (Windows Start Menu → All Programs → Telit Development Platform → Console) and make sure that all the library components are correctly installed. 


To find out the library type:


# ls /opt/crosstools/lib

or

# ls /opt/crosstools/telit/lib


then type:

# ls /opt/crosstools/usr/include


or


# ls /opt/crosstools/telit/include


to find out the library header files.


Whenever the library you want to use is not into the Colinux Development Environment, you can install it. Let’s assume, for example, you want to install the libpthread.a library (which is actually already installed into the Colinux Development Environment). 


Copy the library typing:


# cp /mnt/windows/<PATH>/libpthread.a /opt/crosstools/lib


Copy the header file typing:


# cp /mnt/windows/<PATH>/pthread.h /opt/crosstools/usr/include


where <PATH> is the windows folder where you have stored the library files. For example, if you store them within C:\Temp you have to type:


# cp /mnt/windows/Temp/libpthread.a /opt/crosstools/lib 


and


# cp /mnt/windows/Temp/pthread.h /opt/crosstools/usr/include

Once all the library components have been correctly set up, the application can be linked against the library itself. Under Eclipse right click on the project folder and select Properties as shown below:
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The Properties tab for the application will appear. Now, from the C/C++ Build left menu, select Settings and then, from the Tool settings tab, select Libraries as shown below.
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Now push the Add button (highlighted above) to link the library. Simply type the pthread value when the window below will appear and then push the OK button. 
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Please note that the ‘-l’ linker option automatically completes the library name with the ‘lib’ prefix: therefore there is no need to indicate the full library name (libpthread).

Once libpthread.a has been successfully added to the project, push the Apply and then the OK buttons of the main tab. Now the project using libpthread.a is ready to be compiled.
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6.3 Downloading a file to the target

Once the project has been compiled, you can download it to the target. There are two possible options:


· Downloading the file using the Ethernet/USB port


· Downloading the file using the serial port.

6.3.1 Download through the Ethernet/USB port

The simplest way to download the binary of a project is to use the IDE (note that the telnet daemon must be running in the target).


Highlight the project whose binary is going to be transferred and go to Telit → Download binary to GE863-PRO3 or click on the button highlighted by the red circle in the picture.
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Alternatively, in the Project Explorer, you can right-click on the binary to be transferred, and choose the voice Telit → Download Binary to Target of the pop-up menu:


[image: image58.jpg]ielloWarld/helloye sEclipse Plationm

e G Refedor Nevse Sewdh froes NE fun Wdow hep
rr-E e s?e|a e @6 &5 0o

e ) (T

© §EHelaworid Finclude <stdio.h>

< 4 Binaris

int main(void) {
printf("Hello World:®);

b ) inchdes tien >
e Open
b G Relesse Openwiy >
b8 helloc [ copy. ctiltc
5 paste ey
K pelete Deete
Move.
Rename r2

Import.

2
2 Expart
2 Rafrash e

Exclude from build.

Buid Configurations »
Make targets »
Runas »
Debugas »

Clean Selected i)
Build S elected i)

Bam 3
Compare With »
Replace ith »

Properties Asenter

o merer]







If the transfer succeeds you should see in the console a similar message:
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The binary can be found in the root directory of the target filesystem.


Pay attention that the first method will work only if the binary has the same name of the selected project and if the binary can be found inside the Release directory of the project.


If you need to download to the target any other file than the compiled binary of a project follow these steps:


· Go to Telit → Download file to GE863-PRO3 or click on the button highlighted by the red circle in the picture.
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· Use the file selector to choose the file to be transferred and click Ok.
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Alternatively, in the Project Explorer, if you have in a project the file to be transferred, you can right-click on it and choose the voice Download File to Target of the pop-up menu.
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If the transfer succeeds you should see in the console named Telit Command Output a similar message:
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Alternatively you can choose not to use the IDE:

· Go to Start → Telit Development Platform → Console.


· Copy the files to be transferred in the directory /var/www/apache2-default/, for example opening a terminal and using the cp command:

cp <file_to_be_copied> /var/www/apache2-default/



· From the target shell, within the directory where you want to place the downloaded file, type:

wget http://192.168.121.2/apache2-default/file_to_be_copied
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If the file is an application you need to change its permission to execute it. Therefore type:


chmod 744 filename

6.3.2  Download through the serial port

Make sure your target “Upper=AP UART0” serial port is configured with the baudrate you wish to use for transferring the file. Open a console and type the following command to change the baudrate:


stty ispeed [ baudrate ] < /dev/ttyS1

Then type:

rz --zmodem </dev/ttyS1 >/dev/ttyS1

in order to let the target receive your binary file through the zmodem protocol using ttyS1.

Now use the “send file” option from your terminal (make sure that zmodem file transfer option has been set) to download your application to the target. 

If the file is an application you need to change its permission to execute it. Therefore type:

chmod 744 filename

7 Debugging an application

7.1 Overview


Telit Development Environment allows remote debugging on the target through Ethernet/USB connection. Two applications are needed:

· gdbserver: server part of the debugger which runs in the target; it must be launched every time the debugging starts. The file can be found in coLinux filesystem directory /opt/crosstools/arm-linux-uclibc/target_utils/gdbserver and it needs to be copied in the target using one of the methods seen in chapter 6. Remember to set the executable flag for the file using the chmod command as explained in 6.3.2. You also need to copy in the target (inside the /lib/ directory) libthread_db.so.1 that can be found in coLinux filesystem directory /opt/crosstools/lib.

· arm-linux-gdb: client part of the debugger which runs in coLinux. The file can be found in coLinux filesystem directory /opt/crosstools/usr/bin/arm-linux-gdb. It commands the debugger behaviour and it is used through a graphical user interface in Telit Development Environment provided by Eclipse.

Both the server and the client need to be configured as explained in the following paragraphs.

7.2 Configuring the Debugger

7.2.1 Creating a Debug Launch Configuration

Before start debugging your application, a Debug Launch Configuration for the project shall be created into Eclipse.

The Debug Launch Configuration locates the GDB debugger for Eclipse, locates the project’s executable file (in this case it is used only to look up symbol information), and provides a startup script of GDB commands that are to be run as the debugger starts up.


A Debug Launch Configuration will be created for each project.

Select the menu option “Run → Open Debug Dialog…” to bring up the Debug Configuration Window.
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In the “Debug – Create, manage, and run configurations” window below, click on “Zylin Embedded debug (Native)” followed by the “New” button.
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The Debug “Create, manage and run configurations” window changes to the dialog shown below. Start by making sure that the “Main” tab is selected.

In the “Name:” text box, enter the name of this debug launch configuration (usually the project name). In this example use the “Hello”.

In the “Project” text box, use the “Browse…” button to find the project “Hello”. 

In the “C/C++ Application” text box, use the “Search Project…” button to find the executable “Hello”.
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Now select the “Debugger” tab as shown below. 


In the text box labeled “GDB Debugger:” use the “Browse...” button to locate the “arm-linux-gdb” file. It will be found in the “/opt/crosstools/usr/bin” folder.

Finally remove the “.gdbinit” GDB init script filename from the “GDB command file:” text box.
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GDB can communicate with the target over an IP network/Ethernet-link-on-USB using TCP or UDP.GDB – IP network connection configuration (Ethernet or USB)

Select the “Commands” tab.

If your target is accessible through a network cable, in the “’Initialize’ commands” text window, enter the following GDB startup commands, as shown in the picture below:

· nosharedlibrary


· set solib-absolute-prefix /opt/crosstools


· symbol [ filename ]

· target remote tcp:192.168.121.3:2345

· tbreak main


· continue
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In the previous lines [filename] refers to the binary to be debugged, including the file path (for example the default workspace is /root/workspace/project_name/Release/file_name).


The “target remote tcp” command debugs using a TCP connection to port 2345 on 192.168.121.3 (the IP address you should use in the target if you have not changed default configuration).

Click on “Apply” followed by “Close” to finish specification of the debug launch configuration for Hello debugging. Eclipse may ask you if you want to save this configuration, answer “Yes”. 

The “Source” and “Common” tabs can be left in their default state.

7.2.2 Organizing Favorites


In order to simplify the debug process you can add the launch configuration that you wish to use in the Favorites. For example add the Hello embedded debug launch configuration into the Debug pull-down menu’s list of favorites. 


In the toolbar, click on the down arrowhead next to the debug symbol and then click “Organize Favorites…”.
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Click on “Add…” and either checkmark the “Hello” or click the “Select All” button. 

Finally, click “OK” to enter this debug launch configuration into the debugger list of favorites, as shown below.
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Now when you click on the Debug Toolbar button’s down arrowhead, you will see the “Hello” debug launch configuration installed as a favorite, as shown below.
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Now everything is in place to debug the project.

To debug, it is needed to switch from the C/C++ perspective to the Debug perspective. The standard way is to click on “Window → Open Perspective → Debug” as shown below.
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A more convenient way to switch perspectives is to click on the “perspective” buttons at the Eclipse upper-right window location. Click on the “OpenPerspective” toolbar button below on the left and then choose “Debug” when the other perspectives are displayed.
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Now a “Debug” button is shown below. You may have to drag on the edge to expose all the perspective buttons. You can also right-click on any of the buttons and “Close” them in order to reduce the display to only the perspectives you are interested in.

7.3 Running gdbserver

7.3.1 Remote IP network connection


As previously explained the gdbserver should be present in the target in the / directory and the libthread_db.so.1 in the /lib/ directory.


Be sure your application (also a stripped version of this latter can be used) has been already copied into the target (see paragraph 6.3.1). 


If you are using the IDE, the simplest way to launch the debugger is highlighting the project to be debugged and going to Telit → Start Debugger or click on the button pointed out by the red circle in the following picture:
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Alternatively, in the Project Explorer, you can right-click on the binary to be debugged, and choose the voice Telit → Start Debugger of the pop-up menu:
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Note that the telnet daemon must be running in the target. If the operation succeeds you should see in the console named Telit Command Output a similar message:
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If you want to manually start the gdbserver type in a target shell:

./gdbserver 192.168.121.2:2345 [ filename ] &

If The ‘host:2345’ argument means that gdbserver is to expect a TCP connection from machine ‘host’ (your workstation running Eclipse) to local TCP port 2345.

[ filename ] is your application’s filename with its own path.


It is recommended to let gdbserver run in background adding the “&” symbol to the command line as shown above.

Now gdbserver listens on port 2345 for a remote connection.


7.3.2  Running GDB


To start the Eclipse debugger, click on the “Debug” perspective button at the upper-right to open the Debug Perspective display, shown below.
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If your display doesn’t look exactly like the debug display above, click on “Window → Show View” and select any of the missing elements.

Once the server in the target has been started go to Run → Open Debug Dialog…, choose the debug configuration for the project you wish to debug and click the Debug button.

In the screenshot below there are shown the components of the Debug perspective:
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To start the debugging select the line Embedded GDB under the project name debug configuration row and click the green arrow highlighted in the screenshot.

Now you are ready to debug your application. To set breakpoints double-click on the far left edge of the line. Double-clicking on the same spot will remove it.
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Note in the upper right “Breakpoint Summary” pane, the new breakpoint at line 5 has been indicated, as shown below.
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Use the debug control buttons shown below to control debugging.
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See Eclipse’s Help Contents for further information.
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8 General suggestions

· Using a workspace in Windows filesystem it is not possible to rename an existing project: if you try the project name changes but connection to the files included is lost.

· Using a workspace in Windows filesystem it is not possible to delete a project: if you try the project seems to be deleted in the workspace, but its files are still present in the filesystem.


· Using a workspace in Windows filesystem sometimes Eclipse reports error in preferences saving, however this is only a warning. 

· If Eclipse reports error in saving files containing special characters you have to change text enconding preferences. Go to Windows → Preferences → General → Workspace → Text File Encoding and choose, for example, ISO-8859-1.

· Occasional Xming crashes happen: close coLinux and restart it to solve the problem.

· Using Ethernet on USB with a Windows bridge (ad described in chapter 4) causes ARP problems, i.e. the target doesn’t succeed in communicating with other systems if those haven’t previously sent data to it. This problem seems to be related in the RNDIS driver: a workaround is to manually insert entries in ARP table (for example in a startup script) for linking a NIC mac address to its IP address. The shell command to be used is:

arp –s hostname hw_address



· If the software “Putty” is present in your system be sure that its default configuration is ssh and not serial, otherwise Telit Development Environment applications won’t start.

Appendix A : How to change default IP addresses


Telit Development Environment default installation will create a C class network 192.168.121.0; however it is possible that you already have in your system such a network. In this case, you have to manually change all the 192.168.121.x addresses to a free address space in your network. Follow these steps:


· Start coLinux.


· Go to Telit Development Environment installation directory and run colinux-console-fltk.exe.


· After login (user: root, password: root) type in the console: 

nano /etc/network/interfaces

and modify the rows

address 192.168.121.2
netmask 255.255.255.0

with the proper addresses, then save the file. 


Pay attention that you always need to keep the correct correspondence between addresses.




· Type in the console:

nano /root/.profile

and modify the row

DISPLAY=192.168.121.1:0.0

with the proper address, then save the file.



· Type in the console:

halt

then close the coLinux window.



· Go to Telit Development Environment installation directory, enter in the Xming directory and open the file X0.hosts with a text editor. Modify the rows

192.168.121.2
192.168.121.1

with the proper addresses, then save the file.



· Modify the IP address of the network bridge according to the proper value (see paragraph 4.1.3  for details).



· Go to Start menu → All Programs → Telit Development Platform and right click on the item Console: modify the addresses 192.168.121.2 and 192.168.121.1:0.0 with the proper values, then click Ok. Repeat the same procedure for the items Telit Customized Eclipse, mc and Synaptic.



· Start coLinux.



· Launch Telit Customized Eclipse.



· Go to Window → Preferences and click on the item Telit GE863 Preferences. Modify the addresses in coLinux IP address and GE863 IP address text boxes with the proper values.



· When configuring the target IP address remember to use the new value; see paragraph 4.1.2 for details.


Appendix B : How to make a back-up


If you wish to make a back-up of the entire development environment go to its installation directory and copy the following files:


· root_fs.img


· swap.img


If you want to restore the system to this back-up, copy back the two files to the development environment installation directory.




Please note that if your Eclipse workspace is in Windows filesystem this won’t be backed-up.

Appendix C : Recovering from a serious error

If the development environment doesn’t work anymore you can follow these steps to restore the system.


THIS METHOD COMPLETELY DESTROYS ALL THE DATA YOU HAVE STORED INSIDE COLINUX FILESYSTEM. USE THIS ONLY IF YOU HAVE NOT ANY OTHER SOLUTION TO RESTORE THE SYSTEM!


· If running, close coLinux.


· Go to Telit Development Environment installation directory.


· Double click on the file dskimageC_Cpp_dd_mm_yyyy.exe where dd_mm_yyyy is a date.


· Click Extract.


After several minutes the development environment will be restored. If this method doesn’t work uninstall the entire development environment (including coLinux and Xming), delete the installation directory and try to reinstall it following the steps reported in 3.3.

Appendix D : Copying C++ libraries in the target

By default the target does not have the libraries necessary for C++ applications. In order to copy them follow these steps:


· Start coLinux (Start menu → All Programs → Telit Development Platform → Start Colinux).


· Open a console (Start menu → All Programs → Telit Development Platform → Console).

· In the console type:

mkdir /root/cpp_libraries
cd /opt/crosstools/usr/arm-linux-uclibc/lib/
arm-linux-objcopy --strip-debug libstdc++.so.6 /root/cpp_libraries/libstdc++.so.6
arm-linux-objcopy --strip-debug libgcc_s.so.1 /root/ cpp_libraries/libgcc_s.so.1



· Copy the two files (/root/cpp_libraries/libstdc++.so.6 and /root/cpp_libraries/libgcc_s.so.1) in the target using one of the methods described in previous chapters.


· Move the two files in the target to the directory /lib.


Appendix E :  Upgrading the firmware kernel sources with Kernel Upgrade Tool


Overview


The Kernel Upgrade Tool is a Windows application used for upgrading kernel Linux in coLinux development environment. The updated kernel version depends on the tool version.


Usage


For using the Kernel Upgrade Tool follow these steps:


· Double click on the file Telit-UpgradeKernel-<version_number>.exe and choose the directory where the tool can be unpacked.
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· Go to the directory where the tool has been unpacked and double click on the file

UpgradeKernel.exe

for launching the tool.



· If you have kept the default ip addresses for coLinux and the target then simply click  the Start Upgrade button:
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· When you are ready confirm the action clicking Ok, otherwise Cancel:
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· The upgrade takes some seconds. If the update succeeds it is shown the following pop-up:

[image: image91.png]X]

Upgrade complete:

o






[image: image92.png]© Simple mode
© dvanced mode

T







· If the update doesn’t succeed a pop-up like this will appear:
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· If you have not kept the default ip addresses for coLinux and the target then choose the Advanced Mode of the Radio Button and insert the proper ip address in the coLinux ip text field, then click the Start Upgrade button:
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· If you want to see which updates the tool carry out click on Info → Show Updates:
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Appendix F : Upgrading U-boot with U-boot upgrade Tool

Overview


The u-boot Upgrade Tool is a Windows application used for upgrading u-boot in coLinux development environment. The updated u-boot version depends on the tool version.


Usage


For using the u-boot Upgrade Tool follow these steps:


· Double click on the file Telit-UpgradeU-boot_<version_number>.exe and choose the directory where the tool can be unpacked.
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· Go to the directory where the tool has been unpacked and double click on the file

UpgradeU-boot.exe

for launching the tool.



· If you have kept the default ip addresses for coLinux and the target then simply click  the Start Upgrade button:
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· When you are ready confirm the action clicking Ok, otherwise Cancel:
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· The upgrade takes some seconds. If the update succeeds it is shown the following pop-up:
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· If the update doesn’t succeed a pop-up like this will appear:
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· If you have not kept the default ip addresses for coLinux and the target then choose the Advanced Mode of the Radio Button and insert the proper ip address in the coLinux ip text field, then click the Start Upgrade button:

[image: image103.png]O Simple mode
@ dvanced mode

colinu P:

1921681212









· If you want to see which updates the tool carried out click on Info → Show Updates:
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Appendix G : Transferring files between coLinux and Windows


For transferring files between coLinux and Windows filesystems it is possible to use a program called Midnight Commander (Start menu → All Programs → Telit Development Platform → Midnight Commander).
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It works as a normal file explorer: the window is divided into two columns, each one showing the content of a directory in the filesystem. Midnight Commander allows executing all normal operations on files (copying, renaming, deleting…). You can find the content of your Windows filesystem inside /mnt/windows. For help press F1.
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